Audio Dropouts, Bogus error message "Too Many Tracks Recording"

I’m using Cubase Pro 9
I was having problems last year with occasional audio “dropouts” (during recording or playback), and occasionally recording would abruptly halt with an error message “Too Many Tracks Recording” (even though I was only recording 1 track). The problem increased in frequency to the point where, last Fall, I formatted my hard drive and reinstalled Windows and Cubase (and dozens of plugins and other tools I use often).

That seemed to cure the problem. For about 3 days. Then it started happening again, but was infrequent enough that it wasn’t much of a problem. Lately it’s happening more often, and now Dropouts occur every few minutes, and the dreaded “Too Many Tracks” every hour or so. It’s really embarrassing when I’m working with clients.

It was suggested to me that I run Latencymon, so I did, but I don’t know how to interpret the results. Can someone here help me?

After running for a half-hour yesterday, I had results similar to this:

But after running overnight, they looked more like this (sorry I neglected to get a screenshot at that time, but it had the same red message as this one, and I think more than 2 of the bar-charts were in the red. I DID get the text report and will append it below):

The big issue seems to be “Hard Pagefaults” - if I understand correctly, those are caused by “paging” memory from hard drive space rather than RAM, so why would this happen at all when I have 16GB of RAM?

I’m attaching the full report here - I would greatly appreciate any assistance. Thanks.


Your system appears to be having trouble handling real-time audio and other tasks. You are likely to experience buffer underruns appearing as drop outs, clicks or pops. One or more DPC routines that belong to a driver running in your system appear to be executing for too long. One problem may be related to power management, disable CPU throttling settings in Control Panel and BIOS setup. Check for BIOS updates. LatencyMon has been analyzing your system for 19:12:58 (h:mm:ss) on all processors.


Computer name: DRYCREEKDAW
OS version: Windows 7 Service Pack 1, 6.1, build: 7601 (x64)
Hardware: Z68A-D3H-B3, Gigabyte Technology Co., Ltd.
CPU: GenuineIntel Intel® Core™ i5-2400 CPU @ 3.10GHz
Logical processors: 4
Processor groups: 1
RAM: 16301 MB total


Reported CPU speed: 3109 MHz
Measured CPU speed: 1 MHz (approx.)

Note: reported execution times may be calculated based on a fixed reported CPU speed. Disable variable speed
settings like Intel Speed Step and AMD Cool N Quiet in the BIOS setup for more accurate results.
WARNING: the CPU speed that was measured is only a fraction of the CPU speed reported. Your CPUs may be throttled back due to variable speed settings and thermal issues. It is suggested that you run a utility which reports your actual CPU frequency and temperature.


The interrupt to process latency reflects the measured interval that a usermode process needed to respond to a hardware request from the moment the interrupt service routine started execution. This includes the scheduling and execution of a DPC routine, the signaling of an event and the waking up of a usermode thread from an idle wait state in response to that event.

Highest measured interrupt to process latency (µs): 6338.350329
Average measured interrupt to process latency (µs): 3.988367

Highest measured interrupt to DPC latency (µs): 781.548731
Average measured interrupt to DPC latency (µs): 0.821114


Interrupt service routines are routines installed by the OS and device drivers that execute in response to a hardware interrupt signal.

Highest ISR routine execution time (µs): 135.663557
Driver with highest ISR routine execution time: ACPI.sys - ACPI Driver for NT, Microsoft Corporation

Highest reported total ISR routine time (%): 0.124838
Driver with highest ISR total time: hal.dll - Hardware Abstraction Layer DLL, Microsoft


Total time spent in ISRs (%) 0.128669

ISR count (execution time <250 µs): 72786378
ISR count (execution time 250-500 µs): 0
ISR count (execution time 500-999 µs): 0
ISR count (execution time 1000-1999 µs): 0
ISR count (execution time 2000-3999 µs): 0
ISR count (execution time >=4000 µs): 0


DPC routines are part of the interrupt servicing dispatch mechanism and disable the possibility for a process

to utilize the CPU while it is interrupted until the DPC has finished execution.

Highest DPC routine execution time (µs): 1557.360888
Driver with highest DPC routine execution time: storport.sys - Microsoft Storage Port Driver, Microsoft Corporation

Highest reported total DPC routine time (%): 0.054476
Driver with highest DPC total execution time: rspLLL64.sys - Resplendence Latency Monitoring and Auxiliary Kernel Library, Resplendence Software Projects Sp.

Total time spent in DPCs (%) 0.112580

DPC count (execution time <250 µs): 215787681
DPC count (execution time 250-500 µs): 0
DPC count (execution time 500-999 µs): 13
DPC count (execution time 1000-1999 µs): 2
DPC count (execution time 2000-3999 µs): 0
DPC count (execution time >=4000 µs): 0


Hard pagefaults are events that get triggered by making use of virtual memory that is not resident in RAM but backed by a memory mapped file on disk. The process of resolving the hard pagefault requires reading in the memory from disk while the process is interrupted and blocked from execution.
NOTE: some processes were hit by hard pagefaults. If these were programs producing audio, they are likely to interrupt the audio stream resulting in dropouts, clicks and pops. Check the Processes tab to see which programs were hit.

Process with highest pagefault count: msmpeng.exe

Total number of hard pagefaults 156794
Hard pagefault count of hardest hit process: 92986
Highest hard pagefault resolution time (µs): 7470285.403667
Total time spent in hard pagefaults (%): 0.075598
Number of processes hit: 21


CPU 0 Interrupt cycle time (s): 1313.558937
CPU 0 ISR highest execution time (µs): 135.663557
CPU 0 ISR total execution time (s): 356.043880
CPU 0 ISR count: 72786378
CPU 0 DPC highest execution time (µs): 1557.360888
CPU 0 DPC total execution time (s): 288.244747
CPU 0 DPC count: 206681711

CPU 1 Interrupt cycle time (s): 207.017672
CPU 1 ISR highest execution time (µs): 0.0
CPU 1 ISR total execution time (s): 0.0
CPU 1 ISR count: 0
CPU 1 DPC highest execution time (µs): 212.599871
CPU 1 DPC total execution time (s): 3.309396
CPU 1 DPC count: 1143216

CPU 2 Interrupt cycle time (s): 2247.746407
CPU 2 ISR highest execution time (µs): 0.0
CPU 2 ISR total execution time (s): 0.0
CPU 2 ISR count: 0
CPU 2 DPC highest execution time (µs): 179.325507
CPU 2 DPC total execution time (s): 9.259974
CPU 2 DPC count: 3407636

CPU 3 Interrupt cycle time (s): 902.550271
CPU 3 ISR highest execution time (µs): 0.0
CPU 3 ISR total execution time (s): 0.0
CPU 3 ISR count: 0
CPU 3 DPC highest execution time (µs): 227.354455
CPU 3 DPC total execution time (s): 10.708577
CPU 3 DPC count: 4555133

Your hard pagefault latency is quite high. If you haven’t messed with your page file settings, Win 7 should default it as 2x your physical ram and place it on your OS drive.
You should have enough RAM so that it isn’t used much, but some programs use the paging file to store temporary data regardless of how much RAM is free.
I think windows forces your swap to be in contiguous sectors, so I wouldn’t think that a disk defrag would help, but it might be worth an effort.

You are also seeing a high latency via your USB driver. Are you using a USB hub ? if so, you might to bypass it and see if that helps.

If you have any pci/e cards installed they might be sharing a interrupt with the USB root hub. Execute the program msinfo32 and look at the Hardware Resources -> IRQ section. Check to see if the USB driver is sharing the same IRQ as one of your pci/e cards. If so, swap around your cards location or move them to an empty slot to see if that helps.

Good luck and let us know of any progress.

Edit: I looked at your profile at noticed that you are running a M-Audio 1010LT PCI card. You can adjust interrupt latency on a PCI card forcing windows to take longer to service any interrupts produced by your audio card, helping to eliminate audio glitches.

There is a freeware tool called PCI Latency tool PCI Latency Tool Download that allows to you to make that adjustment.
If any of the above mentioned solutions do not help, then you may want to look at using this program.

1 Like

Thanks for the reply. I looked at the page file settings. They’re set to Auto, and it says it has allocated 16301 MB. Should I double that. (Also, my OS drive is a 1TB SSD)

I do have a USB Hub, but I’m not using a USB audio interface. I could probably get by without the hub - I installed it several years ago when it seemed like every software producer had their own kind of dongle key.

I’m using a pair of M-Audio Delta 1010s (not LT, the one with the rackmount breakout box). I may try the PCI Latency Tool, but I’m a little confused. You said forcing Windows to take LONGER to service interrupts would reduce audio glitches - I would’ve thought the opposite would be true. (Which may just mean I understand this stuff even less than I think I do).

I tried a couple other suggestions I found online. One was to disable WAN Miniports in Device Manager (I didn’t even know they were there until I changed a setting to “display hidden devices” - there were several of them - why would Windows want to “hide” any devices)

Another was to change CPU affinity to force audio processing to ignore the first core and use the other 3.

I tried those things and then did some editing in a project. I had one brief dropout over the course of about 45 minutes, which is an improvement I guess, but I’m thinking those approaches may have been a wild goose chase.

I’m running LatencyMon again. The “pagefault resolution time” bar shot up into the red immediately, and after 10 minutes the status message changed from “Your system seems suitable” to “Your system seems to be having difficulty”

I have to go out for awhile, so I’ll let it run and try your other suggestions after I return.

Since you have an SSD OS drive, you probably should just let it use the default OS size and settings.
When I looked at mine, it was set to auto and was using 2x my memory size. Which is weird since it shouldn’t need to be any bigger than your RAM. Who knows it’s windows :grinning:

When the processor receives an interrupt it allots the device (audio card in this case) so many microseconds to do what it needs to do before it services the next interrupt from another device. By increasing the interrupt time your card is able to process more audio samples before the processor moves on to the next device that is requesting cpu time.

I’m not sure if that will help you problem, but it maybe a solution. It’s interesting that it seems to take a couple of months before your system starts to develop problems.

Another option is to start up the task manager when Cubase is running and select Cubase so that it is highlighted and then right click and select CPU Priority and set it to high and see if that helps. It is not permanent and requires you to perform that action every time you start Cubase. There is a freeware program that you can download that remembers the CPU priority setting and sets it each time a program is started. Link: Permanent CPU priority program.

I downloaded PCI Latency Tool, but can’t get it to install. Installation failed with a warning that I have to install using an account with Admin priviledges. When I ran the install as Administrator (which took some finagling, as Windows 7 doesn’t natively allow “Run as Administrator” for MSI files, it crashed with message “This installation package could not be opened. Verify that the package exists, or contact the vendor to verify that this is a valid Windows Installer package”

Is there another, perhaps newer tool for this purpose? (the guru3d site is pretty dated, but then so is PCI I suppose). I saw some suggestions of doing this through the BIOS, but I can’t find any such settings.

BTW I unplugged my USB hub. Didn’t seem to make any difference.

hmmm now this is interesting. In system info, I see that

  • Intel® 6 Series/C200 Series Chipset Family PCI Express Root Port 7 - 1C1C
  • PCI standard PCI-PCI bridge
  • M-Audio Delta 1010
  • Intel® 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C2D
    all share IRQ 18


  • Intel® 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C1E
  • M-Audio Delta 1010
    both share IRQ19

I have 2 Delta 1010 PCI cards in the 2 PCI slots, but I have no PCI/e cards installed at all. Could sharing the IRQ cause a conflict even if there are no cards in the PCIe slots? Should I try disabling the PCI Express Root Ports in Device Manager?

No, do not disable your PCI Express Root Ports or your USB Enhanced Host Controller in the device manager.
Too bad the PCI latency tool didn’t install. I used it several years ago when I was running 2 Delta 1010’s.

IRQ sharing may not be the cause of your audio dropouts, but the latency checker program you ran did show that your worst ISR latency was related to your USB driver which shares the same IRQ as your 1010s.
My PC system bios has the capability to adjust PCI latency, not all motherboards allow that adjustment.

I tried disabling the onboard sound card in the bios (since I rarely use is, I run most audio through the Delta), and also disabled the onboard serial interface (is that used for anything anymore).

Cubase priority was already set to high, but the Delta driver was set to low. I changed it to high also.

It seems to have made the problem worse. (However I was running LatencyMon at the same time as running Cubase - I think that may have a negative affect, although some people have reported experiencing fewer audio dropouts while LatencyMon is running)

I did get Latency Tool to install, but it still won’t run - Windows evidently won’t allow “unsigned” programs to run, still looking for a workaround.

I turned off Windows UAC, which gives the program permission to run, I guess. Still doesn’t work, I get a message that says “Failed to initialize Config Space access” and recommends rebooting and or reinstalling. (I’ve tried both).

Too bad about the latency tool. Probably only compatible with XP.

Hopefully a couple of other forum members can toss out some ideas.

Today I had a session with a client. 4 hours and not a single glitch. I did not change anything, not knowingly at least…

So after my client left I turned on LatencyMon again. In less than a minute the 2nd bar (Interrupt to process latency) shot up into the red and the “Your system appears to be having trouble” warning appeared.

Meanwhile, after 10 minutes, the pagefault numbers remain very low…

Strange. But for now, I’ll take it…

update: two minutes later number of pagefaults jumped to 500, highest pagefault resolution leapt to 50732.685751, and the bar went all the way across the screen again…

I wonder if it’s related to internet browsing.

Delete your page files - problem solved…

1 Like

That’s not recommended because some programs expect a page file and may error if it’s not available.

Looks like your M-Audio driver is having the greatest latency as opposed to your USB driver in your last screen shot.

The computer I have now is fine in this respect, but on my previous AMD955 I looked into this in some detail. It turns out that windows pages for no reason. I disabled the page files and had no probs at all.

1 Like

Yes, Windows can run without a page file. He would find out soon enough if a program requested access to it.

Yes, and you’re not supposed to run crap programs when you are recording and making music. Anyway…

1 Like

“Crap Programs”?

To paraphrase the President:
“I have the very best programs, believe me.”

Have you any antivirus ram eating hog permanently running? Also are you powering anything via usb when you record other than your interface?