Windows 10 updates causing firewire grief with PreSonus Firepod, other interfaces

Windows 10 updates causing firewire grief with PreSonus Firepod, other interfaces
0.0 0

#1

So last year decided to try getting a used computer for the rehearsal studio and it came with Win 10 32bit preloaded. It is a bit old HP laptop but it seemed to work good and had the most important thing - a firewire port.
Everything installed and worked as a charm until at one point during rehearsal the FP10 won’t sync and Device Manager came up with the FP10 device or maybe 1934a device listed under as “disabled”. Enabling it continued to work. At about the same time it started causing the same issues with my Edirol audio interface and that one locked up and needed to be reinstalled. After reinstall it works.

The FP10 and firewire interface alas did not. So I tried uninstalling and reinstalling the 1934a firewire controller drivers, even installing the 1394 OHCI Compliant Host Controller (Legacy) as recommended by several sites and Microsoft and nothing. Reinstalled the FP10 interface several times.

The FP10 works without a hitch on a Win7 PC, so it is not that unit.

Only other thing I can remember is installing Kaspersky Total Security or something like that which has a software part that controls which apps run and are outdated, etc. I uninstalled that before trying to restore the driver installations.

At this point, honestly, I’ll take any suggestions.

I am thinking of rolling this PC to Win7.


#2

TIL Windows 10 has a 32-bit version… I had no idea!

Firewire drivers on windows 10 can be a bear at times. Silly question, but did you make sure the interface was on before the computer was powered up? Just seeing if that makes a difference for you


#3

if I recall correctly (and I may not), Windows 10 only really supports a certain firewire card chipset. I don’t remember which off the top of my head though. I use 2 FW interfaces and before I upgraded my studio machine to Win10 I had read to make sure the FW card was using the correct chipset or I was likely out of luck. I’ll have to do some fact-checking on myself but I do recall having to figure that out.


#4

TI chipset afaik on this one and it worked fine for about half a year. Then Windows decided to poop it up in the update or something Windows does. I am thinking probably the update since Win10 now has a mandatory update route whether you like it or not. It also disabled my UA-4FX interface which is USB. That one came back after the reinstall. The FW did not.

Tried all kinds of power up configurations, interface first, PC first, both together, interface after PC powers up - nada.


#5

My old PC on Windows 7 had a VIA firewire card and chipset and worked fine until I updated to Windows 10. After the update the card was completely useless and after checking the Focusrite website and talking with some Windows people via forums, I found out that the VIA chipset wouldn’t work. I purchased a new PCI TI chipset card, installed it on my system and have not had a problem since. You can check by going into device manager and looking at your IEEE 1394 controller. As far as I know, only the Texas Instruments firewire works on Windows 10.


#6

See though, the controller worked in Windows 10 as the PC came Win 10 stock. Worked fine for about 6 mos.
Microsoft force feeds you updates whether you want or not (it is a Win10 “feature”) and the update broke that and my USB interface, both at the same time.


#7

That sucks. Does it let you roll back the update? I should check into that!


#8

I disabled that option as it is recommended to increase recording performance. Now I guess I’m paying for it :frowning:


#9

I’ve had a TC Desktop Konnekt 6 interface running on Firewire on Windows 10 (and previously Windows 7) with no issues using cards with the TI chipset. VIA chipset implementations seemed to be hit-or-miss so I stick with Texas Instruments.

You said you already tried the 1394 OHCI Compliant Host Controller (Legacy) driver in the Microsoft Knowledgebase article KB2970191. A thread concerning installation on Windows 10 might be helpful too.

Is your Firewire interface integrated on your motherboard or is it a card? If it’s a card (and assuming you have another suitable slot on the mobo) you might try moving the card to another slot.

Hope it helps.


#10

It’s part of the mobo. That computer also has an expansion card, I might try that expansion card just to see what’ll happen as I have a firewire express slot expansion card which is how I connect on the other PC.