Strange-looking waveforms – am I doing something wrong? SOLVED!

Strange-looking waveforms – am I doing something wrong? SOLVED!
0

#1

I’m not even sure how exactly to ask this question, but here goes…

I have two songs that I mixed, song A and song B. When I look at the resulting wave files in Audacity, I see two entirely different-looking waveforms: the first one (top one, song A) is more typical of what I see when I mix my stuff. strong, healthy signal, no clipping. This particular wav file (per YouLean) has an integrated LUFS of about -15 dB, ST LUFS is about the same, sometimes 2-3 dB higher. True peak is -0.6, which is all good. The resulting file sounds full and nice.

The second mix, song B, sounds fine to my ears, but is clearly audibly 1-2 dB softer. That waveform has much narrow files for both channels. Strange thing is that that file is louder in volume than the first, per YouLean (-14 dB integrated LUFS, true peak -0.6). Also, the waveform looks smaller and lower in volume:

I cannot get them larger, closer to what the first waveform looks like, without increasing the volume significantly, without a limiter (see below). So now that waveform looks closer to what I “think” a healthier waveform should look like; however it is not a healthy waveform: integrated LUFS now is -9.3 and true peak is +6.9:

If I slap the L1 on with those settings, ouch! Integrated LUFS -8.4, true peak 0. And check out the waveform:

Last, with THIS one, I got the waveform to look “closer” to the one in song A by pushing the volume up ridiculously high again, and only using L1 as a limiter, with no compression. But to accomplish this I wind up with -9.6 integrated LUFS. Not good at all.

So, granted, the first song is a “louder” rock sound, the second is softer acoustic, and maybe that’s why the second waveform is so much smaller. But that doesn’t make sense to me: I’m thinking -15 LUFS is -15 LUFS is -15 LUFS – that the waveforms should look similar if the loudness levels are the same, no? They are volume matched, the waveforms shouldn’t look so different.

I’ve never had this difficulty with another wav file. Not sure what’s going on, or even if it’s important? I’m inclined to just go with the first file, as LUFS #s are where I want them to be and it sounds fine to me (and nobody is going to see my wav file!). My question then is whether I’m still overlooking or missing something significant, or doing something wrong. Maybe I’m just being neurotic (I’ve been called worse!), but it just seems strange.


#2

There’s something screwy with the display. That second one does not have a true peak of -0.6dB. Do you have the gain on the track in audacity set to something?


#3

Yeah, that’s exactly what’s puzzling me! I cannot figure it out.

REAPER’s meters are showing RMS around -22 with peaks at around -6 to -5. That’s consistent with what I’m seeing in Audacity. You’re right: the second waveform is between -0.5 to +0.5, which according to the manual corresponds to about -6 dB on the Meter Toolbar.

But YouLean as well as dpMeter2 (TBProAudio) both show integrated LUFS around -14 dB with a true peak of -0.2 or so.

When I try increasing the volume to get the digital peak meters higher – but still well below 0 dB in Audacity or in REAPER’s master buss meter – it goes well beyond the true peak. Strangest thing to me. I’m stumped.

At first I thought it was cuz of some sharp transients from the kick or snare or something, but that’s not difficult to fix with compression. I did that. even used a soft clipper. No change. I’m “stuck” having Audacity/REAPER showing digital peaks at -6 and true peaks just below zero.

Any thoughts what I could be missing? Makes no sense to me at all.


#4

That looks like when you import a 16 bit song into a 24 bit project. Is is it the other way round?


#5

It looks like it does to me. Am I missing something?

Edit: Forget that - I mis-read the OP.


#6

Audacity manual says .5 on their vertical ruler corresponds to -6 dB, which is what my meters in REAPER are giving me. I think that’s what Boz was observing? And when I play it back, audibly it is several dB softer than the first song.

Vaughan and I have been chatting on this in PM. No reason. It dawns on me that I should copy some of that to the public post, cuz it’s good stuff.


#7

Exactly how/where are you measuring these files? Are you using an LUFS meter in the DAW? Or are you measuring the actual rendered file?


#8

Here, from Vaughan and my discussion on PM. Great stuff, Vaughan. Thanks.

I’m really hoping I can figure this out!


#9

It looks to me like you have exported the second track with the master fader down. If you normalise the rendered file it will ‘look’ like the first one, and may well be in the ball park for loudness.

If you are doing your LUFS measurements in the DAW as opposed to actually measuring the rendered file that could explain the readings.


#10

Yeah, I agree. And I was careful to be sure the fader was not low. I did try raising the volume to bring the waveform up, but when I do that, the LUFS integrated gets very high and true peak shows clipping pretty badly.

Interesting. I’ll check the rendered files separately and report back. Thanks.


#11

“Was not low” doesn’t actually mean anything.

Some people are probably going to disagree but in my opnion the fader should never be anywhere other than 0db when you are mixing. If you’re clipping as a result then re-balance the mix and use some limiting on the two-bus if necessary. If you don’t work this way you are always going to struggle matching up the dynamics and loudness of your recordings.


#12

Oh, my GOSH! This was driving me crazy. I finally got it figured out. Well – let’s give credit where credit is due: Vaughan pointed me in the right direction. He PM’d me and suggested I check my pan law settings in REAPER. Bingo!

I had set my pan law settings to -6.0, so that the volume of tracks panned to the side were accurately reflected when I mix in mono. The idea is that the pan law, as I set it, balances things so that the center is attenuated 6 dB relative to the sides. Apparently (I might not be describing this correctly; please correct me if so!), the digital peak meters in REAPER reflect the signal in the center, so if I raise the volume on the master so that the meter reads, say, -1.0, the true peak meters (also picking up on the sides) are peaking to high heaven. 6 dB too loud.

The fix was to switch the pan law so that, instead of attenuating the center by 6 dB, it left the center alone but boosted the sides by 6 dB:

51%20PM

I can’t honestly say I fully understand why that is the case, because it would seem that attenuating the center would be the same as boosting the sides, but it is not.

So my problems is fixed by either changing the pan law to 0 dB OR by leaving it as it was and checking gain compensation (boost pans).

THANK YOU all, for your help with this. Vaughan, you’re awesome, man! I don’t know that I’d ever have figured it out.

Again, I don’t understand exactly why it works, but I do understand that if I check the pretty little box my waveforms are normal again. Whew!

I’d be curious if someone could explain it to me.

Also, I’m going to start a new post about pan law and pan mode settings.


#13

I could try to explain it but , nah…

Kenny already did it really well, right here.


#14

Yeah, I listened to that, and his other video on pan modes. It’s excellent. He doesn’t explain, though, why the boost of the sides “works” but not boosting clips does not work, in spite of the same -6.0 or -4.5 or whatever pan law. Any insight on that?


#15

er… none. what is a clip? Ive never bothered rendering stuff within projects in reaper, if thats what you mean…

Kenny is a good guy, he might be able to answer it (and maybe even add that part to his video).

http://www.kennymania.com/pages/contact-us/


#16

Hm,m. I have no idea what the word “clips” is doing in that sentence. I could just have well said “bananas” there and it would have made as much sense. :slight_smile: Maybe it was autocorrect or something.

All I meant was that under pan mode, if I check Gain compensation (boost pans) it works, but if that box is not checked it does not work. Whether you boost the sides by 6 dB or cut the center by 6 dB, it would seem they both would be the same thing, but alas they are not. If you do not select the gain compensation box, it throws off the metering, which will be 6 dB lower (and that’s what was going wrong in my OP).

Sorry for the confusion. Bananas. :slight_smile: