Reaper issue

Reaper issue
0

Need a little help with a Reaper issue. I recently added some RAM to my computer, and reloaded EZ Drummer 2 in 64 bit. Reaper still saw it as 32 bit, so eventually I deleted and reloaded it as 32 bit so no extra .dll files were hanging around. EZ Drummer seems to work fine.
Here’s my problem: I’ve been working on a new project with a tempo of 114 BPM, and after adding a number of tracks and saving, when I reopen the project I need to move the rate bar to 1.09 to get it to play at the right tempo.
To add to the confusion, I added a keyboard VI, saved it after rendering, and when I reopened the project, I had to auto tune it up about a pitch and a half to get it to playback in tune with the project.
I recently started using a Motu M4 interface, so just in case I updated the driver and verified Reaper and the Motu were at the same sampling rate. Does anyone have any ideas on how to fix this?

Sounds like a sample rate issue for sure. Gauging by the numbers I’m guessing there is a 44.1/ 48khz mis-match going on somewhere. ( ie 48 div by 44.1 = 1.088)

Reaper has preferences you can adjust with regard to setting a per-project sample rate, as well as whether it automatically keeps the original sample rate of the material or adjusts it to suit the project sample rate. This sounds like some kind of combination of those type issues.

Reaper also has a setting where you can get it to automatically set the sample rate on your interface according to the sample rate dictated by the project - that is worth checking too.

BTW, are you running the 64 bit version of Reaper?

1 Like

Yes, it is 64 bit. I’ve hunted around for sample rate mismatches but haven’t found added. I added an organ VSTI track, and rendered it back into the project. I had to autotune it 10.5 semitones to get it to play back in pitch.
I guess I have to have a few drinks and start messing around.
Fun?

I’d say this is just an issue of Reaper not being pointed to or “seeing” the 64bit version of the .dll file. I’ve had that issue before with certain plugins. You have to set the right path file name in the plugin preferences.

Yeah, I thought that could be causing it, so I actually uninstalled the program entirely, and only reinstalled the 32 bit version. I then searched for any remaining .dll files and didn’t find any.
Another weird thing, the tuner on S-Gear was out of calibration too; it showed A440 but was a half step and a few cents flat. A tuned A string showed as being way flat of A flat. S-Gear has no known problems with the tuner.
May have to try uninstalling and reinstalling Reaper if I don’t find something more obvious. Seems the problem involves both sampling rate and VSTs, but I’m not figuring it out quite yet.

I’m guessing it has something to do with Motu being aligned closely with Mac hardware, which (as I understand it) tends to default to 48khz as a base sample rate. Are you using Mac or PC?

It’s a PC. Should I try switching the Motu to 48k?

It might be worth a try just to see what happens… but I’m guessing it is more likely to be a sample-rate preference setting in Reaper causing the issue. There are a myriad of sample rate options under various menus.

1 Like

Okay, it might be fixed. I called Motu, and they directed me to the sound settings in Windows, which were set at 48 instead of 44.1. I’ve changed all that and deleted the drivers for my old interface, and so far it is working properly. I’m presuming the Lambda interface was set for 48, or Windows defaults to 48. Thanks for your help.

2 Likes

Cool! Great to hear you got it sorted!