LoFi Vintage Clipper - FREE

LoFi Vintage Clipper - FREE
0
#1

LoFi Vintage Clipper from Nembrini Audio is FREE for a limited time.

From the About page:

Blockquote Nembrini Audio was born from the experience of Igor Nembrini , who has been involved in the creation of the most famous guitar amp plugins on the market for more than ten years.
Our emulations start from the exact digital reproduction of the analog circuits but are then finely tuned by ear to obtain maximum fidelity to the original sound.

I just installed this last night and gave it a quick once over. I love the simple and intuitive UI. And this plugin sounds as good as it looks. This could fit right into the SoundToys line-up - it’s a definite keeper!

FYI - It uses iLok Cloud which does not require a dongle, but does require you to be connected to the internet.

3 Likes

#2

i-see-what-you-did-there-funny-picture-19229

3 Likes

#3

Hey! I don’t make up the rules. I’m just spreading the FREE plugin love. :heart_eyes:

Seriously though, IMHO, after a quick test run last night, this one is worth the registration hassles. I wish the best for this new Dev, I can imagine it’s a tough market out there. Get 'em while they’re hot!

0 Likes

#4

Is this plugin any good for rock vocals?

0 Likes

#5

I don’t know for certain, but I would guess yes. You have a wide range of FX between the distortion and the saturation. I really like the saturation too, it’s smooth and warm. So there’s another vote for processing a vocal. Heck, try it out, you can’t beat the price!

1 Like

#6

I just found this:

1 Like

#7

I’m having all sorts of problems activating the plugin. Now I’m getting a pop-up stating that “The code redemption limit has been reached. Please enter a different code”. Earlier I got something that told me I had to purchase an ilok. I’m already registered with ilok but I don’t have a dongle. Man, this stuff gets pretty convoluted sometimes. How do I get a new activation code?

0 Likes

#8

When you “check out” on the website, you will get an email with an Activation Code. After I got the code, I started the iLok License Manager and added that license to it. The email will also have a download link. As far as I can tell, you get to download the installer just once. Run the installer. Then, when you start your DAW, it scans for plugins, an iLok message will come up and say it’s verifying the license…

I believe you can also install the plugin, then on first use, enter the license code that was sent to you. HTH!

1 Like

#9

Yes, that’s the way I tried to install it, but when it didn’t work I tried downloading the plugin again. As you said, I probably can’t use the second download. I sent a message to that website. Hopefully I’ll be still be able to use the plugin.

Thanks for your help Miked!

0 Likes

#10

Happy to help! Do you still have the installer that you downloaded initially? You could re-run that.

1 Like

#11

I can’t seem to find it. I’m not sure, but I think when I downloaded the installer for the second time it replaced the first download. Not really sure though. I’ll check around some more to see if I can find it. Your help is much appreciated! :+1:

0 Likes

#12

If you don’t specifically tell it where to download, it should still be in your default download folder. Good luck!

1 Like

#13

I tried reinstalling the plugin again by clicking on the link you shared in your original post. Everything seemed to be working properly but now I have a box that opened saying,

"Select a Location", “This license can only be activated to an ilok. Please plug one in.”.

Is this suggesting I need to have a physical ilok? If not, how do I “plug one in”, as it is suggesting?

0 Likes

#14

Hmmm. In the iLok License Manager, did you add the “Cloud Activation” and register your license to that? (What a PITA.) Mine looks like this now:

image

0 Likes

#15

I’m looking at my ilok License Manager and I don’t see any “Cloud Activation” or words to that effect. Am I supposed to find the “Cloud Activation” there? Mine doesn’t appear to have that.

Man, I’m sorry for being such a pest !

0 Likes

#16

Yes, you have to add that piece. Are you on the latest iLok software? If not, then update. Now I’m trying to remember how I added that Cloud piece. Maybe up under the File menu? Look around up in those menus, there should be an “Add Cloud” or something like that…

1 Like

#17

Wow!!!

Finally got the plugin activated. Updating the ilok License Manager and restarting the computer seemed to do the trick. I just downloaded the License Manager earlier tonight and I thought that it would have come with the updates installed already. There were so many weird issues too. You wouldn’t believe how convoluted that process was. I can’t even begin to explain the steps it took to get through that mess. :tired_face::scream: Thanks for sticking with me through that hellish journey! I really appreciate your help! :+1: :slightly_smiling_face:

0 Likes

#18

NP - I just hope the plugin is worth it to you!

1 Like

#19

Hey @Wicked , It looks like people are having trouble installing over on the Cakewalk Deals forum too.

How you’re liking this plugin?

0 Likes

#20

I’ve only tried the plugin on a lead vocal so far. I can’t really say if I like or not when it’s used in that capacity. I’ll check it out more in the next few days.

I have one song with a vocal that’s really rubbing me the wrong way. I blame it partially on the inexpensive condenser mic I’m using…I always get that thin, irritating 2 K to 6 K bite, especially when I’m singing higher notes and incorporating a raspy, raunchy voice. I have other songs that work fine with that kind of vocal but this particular COVER song is really perplexing me.

I want to try the LoFi Vintage Clipper on bass, guitar and maybe even drums too, but first I’m going to see what it can do for my vocals.

1 Like