I hate to bother you all with this computer/recording issue

I hate to bother you all with this computer/recording issue
0

#1

I have posted this a few weeks ago over on Bandlab’s site being that is what I am using and all of what they suggested on their forum has not worked. Here is the issue, after about 15 minutes of using Sonar x3 or the bandlab version, when I click the mouse on certain buttons, such as the recording arm button, I hear on audio pop come over the monitors. After one or two pops over the monitors, I find there is no longer sound coming when I play back. I can see the meters showing sound but I can’t hear it. There would always be an audio pop sound before I lost sound on the monitors. Sometimes if I keep clicking the play button, there would not be a pop and it would play sound out the monitors but now it does not come back. I have to shut Sonar down and reopen it to get the sound playing again and no pops and sound through the monitors. I thought it was my interface so I got a new one and it is doing exactly the same thing with the new interface. It only does this when using the recording programs. I have adjusted the buffer both up and down and it still is the same. I am trying to figure out what needs to be fixed. I am losing my mind because I really can’t record with this happening so much. Thanks in advance for anyone willing to help.


#2

Probably a digital sync problem between two devices. My only real world experience of this goes all the way back to midi time code and SMPTE, probably 15 years ago, trying to lock two digital devices together. Its possible you have two devices freewheeling on their own timecode.

Somebody here should be able to connect the dots for you if you list the equipment you are having issues with.


#3

Not sure if I can offer much as I no longer use Sonar. I switched to REAPER years ago and couldn’t be happier. :slight_smile:

So, from your description above, I couldn’t tell: it seems you’re describing that when you re-open Sonar it works? I’m confused. I assume you mean that it only works briefly and stops again? Could you describe that in more detail?

I would guess you’ve rebooted and it hasn’t helped. Especially dealing with sound and video, I sometimes have inexplicably inconsistent behavior that goes away with a reboot. Strange, but that’s the way it is.

Another consideration: How much RAM do you have? Also, how old is your computer? Operating system up to date?

Also, check the configuration for the sound device BOTH in Sonar and in your OS preferences. E.g., on Mac, go to System Preferences > Sound and check to see what the output device is. It should be the sound module you’re using. Need to check it inside Sonar as well, as it could be different there. Just a thought.

Also, IDK how to do this in Sonar, but there should be a way of checking your routing. In REAPER there’s an actual routing grid: each track needs to be sent to the proper output bus (monitor) on your audio device, either directly or thru an aux bus. If it doesn’t go to the monitor, you’ll get no sound.

So, some diagnostic things …

Have you tried opening an entirely new project and recording a live track and playing it back? Or is it limited only to the specific project you’re working on?

Double-check that your connections are good on the audio device. Try different USB ports from your computer. Bad port? Maybe offensively obvious (especially since you bought a new device!) but when trouble-shooting, I get compulsive!

The OTHER thing you can do is try another DAW or audio-recording app like Audacity. Again, REAPER is free to try. If it works with either of those, then you know it’s a config problem in Sonar. If it doesn’t work with Audacity or REAPER, you can safely assume it’s not Sonar. If so, you have it narrowed down to three things: bad audio device (but not likely, cuz you just replaced it), bad cables (unlikely, as I’ve never, ever found that to be the problem – but possible), or a hardware problem with your computer (I’d vote for RAM or a bad USB port).

Oh, and are you running your USB thru a hub? That might not (probably won’t) work. Needs to run direct.

Them’s my thoughts. Hope you figure it out. When you do, please post! Good luck!

Tesgin


#4

Yes, program works for about 5 minutes and then the loud pop sounds and I lose the ability to hear anything.


#5

And another thing…

:slight_smile:

That “pop” comment has me wondering about something.

I’ve experienced this in REAPER on more than one occasion: sometimes I turn on an effect or a buss that boosts a signal so high that a track clips to high heaven. “Usually” REAPER will mute the offending track, but sometimes, depending on where the offending track is in the signal chain, it actually mutes the master buss. Sounds funny but it’s easy to miss and goes away when I reopen the program (which reverts it back to its last save).

Just a thought. It’s happened to me more than once and stumps me every time!

Again, though, if you’re not having the same problem in a new project, it likely isn’t that.


#6

The computer is a Dell and it is about 8 years old. I shut the windows 7 updates off because it always altered something with the computer. I was constantly trying to do a system restore prior to a windows update.


#7

checking my ram right now. Should I just get another computer?


#8

8 GB ram


#9

Probably yes, but check on some of the other stuff first. I’d love to see if your sound module works properly with REAPER or Audacity. Also, they’re going to be less of a RAM/resource hog than Sonar.

8 years is old for a PC; but if you have enough RAM it can handle probably most projects that I would do. FWIW, I am running a 2012 Mac Mini with 16 GB RAM. That monster can handle anything I throw at it (well, except Mastering the Mix’s REFERENCE plugin! That beast is cool but it’s a pig. It’s the only plugin I have that will crash REAPER. Ugh! But I digress!)

:slight_smile:


#10

Here is what I think might have caused it. A few months back I realized that I never saved my projects into individual folders so after asking on the Sonar forum what to do, the answer was to open each and every project and save it to a folder with the project files in the folder. So I did that and then deleted all the files for all of the project, it was about 800 songs/projects. It seems like this issue started to happened shortly after doing that. I would love to try and keep this computer going but it has also been making that famous computer grinding hard drive sound for about a year now. :hushed::smirk::pensive:


#11

I realized that I still have an old program called ProTracks Plus made by Cakewalk. I opened it and played some songs and had no pop sounds. So my guess is it is something to do with Sonar and Bandlab. This is one of those things where it’s really such a small thing but it’s also a huge deal if you can’t record. You want to buy a new computer when you see smoke coming out of it, not a little pop sound being made. :face_with_raised_eyebrow: Looks like I need to bite the bullet and get a new machine and start the whole Mac vs Windows debate. :thinking:


#12

Thanks for helping out my friend. :blush:


#13

I updated my old laptop to Windows 10 from 7 after I began to have bad behavior that messed with sound and video, but only in specific ways. I think it is partly how over time all those updates somehow have a hard time with the old hardware. 10 seemed to help overall, but still after restarts my windows sound settings gets reverted to 48k from my setting of 44.1. That just makes the sound play all garbled. Solution is simple- I have to close Reaper, open Sound Settings Advanced to select 48k and test, then switch back to 44.1 and save. Ridiculous! But I can work, and you can’t. Other problem was computer crashing playing specific video formats in specific programs. In fact, the video I will shortly be posting of my newest song that I just produced on my laptop would not play in 10’s native player, and it popped me a message I needed to buy this 99 cent codec for mp4. So I did, and then the darn thing errored when it tried to install, and with no clear error message.

However, I can play the video in 5K Player as well as on Youtube , so I have another workaround; regardless, it all points to some kind of hardware/driver conflict. Maybe.

I also have one older VST synth, IK Multimedia Sonik Synth 2, handy although a little old and outdated, that will consistently (and yet randomly) decided to drop the sound from one or more tracks. I have to go into the FX, select another instrument, which then works, and then reselect the instrument I was using. I’m not sure if it is that too high a volume issue described above, but it is annoying but not a showstopper.

I am saying all this because you have 800 files (a lot!) on an old hard drive in an old PC. It would behoove you to try to clone that PC and get it all on a new PC while it is just grinding and not dead. It might fix your problem permanently as well. It will be a little painful and tedious. I had to replace my 500GB HD a year ago and I (with help) put in a 1TB SSD, which worked However, there were a couple cloned settings that badly messed up the SSD that I had to google and change. But now that some time has transpired, my equipment confidence has settled down, so long as my weird problems don’t get worse.


#14

OP you describe the reason why I moved out of Sonar so many years ago :slight_smile:

I think what’s happening you’re losing your audio interface sync within Sonar and it is dropping the “Audio Engine”.
I have the same version installed and you should go through the audio interface setup:

Utilities: Audio Midi Setup there’s a little arrow under the basic saying “Advanced”, click on that.

In driver mode you would have several options, in my case WASAPI Shared seems to be doing best although you’re really supposed to use ASIO. Try them out anyway and see if you fare any better. I elected not to share my results with Bandlab on my interface setup.

If you’re looking at alternateve free DAWs you might want to check out Tracktion. It is a no frills DAW but its drivers and audio interface handling is much more solid IMO. I use Bandlab Cakewalk at the moment mainly for the THD built in amp emulator to rehearse bass tracks over Youtube videos.

You never mentioned what interface you’re using or maybe you did but I missed it. There should be options to increase latency on its driver, look into that as well.


#15

The fact that it works with another DAW suggests that Sonar itself is “probably” the bigger part of the problem. Check the settings withing Sonar, as described above, to make sure the driver is properly loaded for your sound module. Make sure you have the most recent drivers for that too, BTW.

Sonar, like I said, can be a resource hog. Might wanna consider increasing to 16 GB RAM. When I made that change, huge difference.

Also, BTW, it’d be helpful to know whether you’re running 64 or 32-bit. 64 is more efficient. I had glitches when I used 32. 32-bit apps can only access 4 GB or RAM. That’s a huge bottleneck on an already slow system.

At a minimum, replace your HDD immediately. Make sure everything is backed up ASAP. If not, you will lose all your hard work through the years. 800+ projects! Yowza. You’ll be sick and nauseous and reaching out to everyone on the forum to help and we won’t be able to help you! You’ll get depressed and become bitter and cynical. You will lose all your friends and will slip into a deep state of despair and lose everything in your life you now hold dear. Life will become futile and you will be without hope. It’ll be awful. Cough up the 100 bucks and get a new hard drive! :grin:

OR put the cost of a hard drive towards the cost of a new system. Heck, I just bought a 2018 MacBook Air for $680 on eBay. 8 GB RAM, 250 GB HDD. Purrs like a kitten. Stable as the day is long. It’ll last me another eight years easily. I actually have, in addition to three 2012 MacMinis, a 2007 iMac and a 2007 MacBook. All still run. No maintenance or repairs.

Personally, I’d upgrade the computer, which will get you more RAM, newer and larger hard drive, faster CPU. Heck, if your computer’s eight years old, there’s a good likelihood it won’t even run 64-bit.


#16

I thought you couldn’t buy used Macs?


#17

Sure you can. You can even transfer AppleCare licenses if not expired.


#18

I think that is what I am going to do then, buy a mac and switch to pro tools. Do you have a trusted source on ebay for macs?


#19

wait… protools? seriously?

Go Apple imac and Reaper (or something else free/ low cost). Its actually better, I kid you not.


#20

I always heard that the whole recording industry uses pro tools and that was the best. :grimacing: