DAW says peaks are +0.3, but true peaks are -0.6? SOLVED!

DAW says peaks are +0.3, but true peaks are -0.6? SOLVED!
0

#1

Title of post says it all. My DAW (REAPER) tells me that my mix is clipping, 0.3. However, my LUFS meter, which is YouLean Loudness Meter 2, says my true peak is -0.6. I also have a limiter on my master buss, with a ceiling set to -0.7.

Ugh. What am I missing? I’m “thinking” that that’s not unusual, and that a slight bit of clipping is okay, but that what I really wanna watch is my true peaks, cuz that’s what’s gonna determine whether it clips on another audio system after digital to audio conversion.

Am I correct in that? Or is something screwed up? (please tell me I’m correct) :slight_smile:


#2

The true peak shouldn’t be lower than the peak. Is the limiter adding 0.7db after YouLean, or something like that?


#3

(you were supposed to tell me I’m correct) :frowning:

No, YouLean is the last thing in my signal chain. The L1 is immediately before YouLean. This pic shows my peak on the master at +.2, and YouLean at -.6:

I’ve duplicated the same thing using other limiters as well (e.g., George Yohng’s W1). My settings on the L1:

My DAW is REAPER. So, is this a metering problem in REAPER? YouLean is purportedly pretty reliable, so I don’t “think” it’s that. I’m stumped.


#4

Is this an “inter-peak sample” issue? Try putting a clipper just before your limiter to lop off those quick transients…


#5

A couple of things:

  • Check the actual level of your master fader. If, for eg. it is set to +0.9 instead of 0, it might cause the result you mentioned above.
  • Check the routing of other tracks in your DAW. Depending on the architecture of your DAW, there may be a chance that one of the tracks in your project could be bypassing the master fader and going direct to the overall audio output of your DAW.

The reason I mention these things is that I have had the same thing happen - more often than I’d like to admit!


#6

Thanks for the suggestions. yeah, I double-checked and the master fader is set to 0. Routing is good. Everything goes thru the master buss and nowhere else.

Good suggestion. I put ReaPlug’s JS: Soft Clipper/Limiter before the L1and that seems to have stopped the clipping (which is good!), but the true peak is still giving me a reading of -2.5 per YouLean and basically the same on TBProAudio’s dpMeter3, which is lower than the digital peak!

The other thing I did is to render a section of the song to a wav file and then import it into REAPER in a fresh project. Interestingly, the true peak of that section before exporting was -2.4 true peak; using the same meter in the new project, the meter gives me a true peak of -1.6 dB. Also, the peak meters in REAPER are discrepant: before exporting that segment of the song: the meters read -1.5 and -2.1 (left and right). After rendering to wav and importing the same segment into a new project, the meters on the wav are -2.1 and -1.8.

So several things seem to be going on here: one is that the W1 doesn’t seem to be quite the brickwall limiter that we thought it was. I know that’s harsh, but IDK what other conclusion to draw!

The other is that there seems to be some metering “slop” in REAPER as well as with the two apps measuring LUFS.

I’ve sent in a support ticket to YouLean and to TBProAudio. See what their thoughts are.


#7

I posted this problem over on the REAPER forums. Got a ton of participation there. For any REAPER users, if you haven’t used that forum, they’re amazing. It’s uncanny how knowledgeable and helpful those people are. A really nice complement to IRD.

Anyway, found the problem (yeah. As if I found it! Someone over there found it and explained it to me!).

Turns out that I had some volume automation on the master buss; I had no idea that that volume automation was post-fx. I assumed since the master fader in REAPER is pre-fx, that the fader automation would be also. So, REAPER has another option of pre-fx volume automation, but the default that I chose was indeed post-fx. I.e., it was automating the volume after my YouLean meter and dpmeter3! Hence, the digital peak was higher than my true peak.

Ugh. Embarrassing. Live and learn. I knew I could solve the problem by just lowering the volume and steering way clear of 0.0 dB. Improvising, but not really understanding. Glad I hung in there. Learned something new. Had to share it, in the hopes that I’m not the only one to have missed something like that.

Man, the support and help I get in communities like REAPER’s and HERE are unparalleled in my experience. Very humbling and very cool.

Thank you guys for welcoming me on this journey with y’all. Have never had more fun with my music. :slight_smile:


#8

Nice that you got some answers! And thanks for the confirmation on that, I had asked it a few years ago in RR or IRD. I learned on Pro Tools, and learned about this in “audio school”, and that Pro Tools master fader automation was (IIRC) pre-FX which means that if you do a fade out and have a compressor and other FX on your Master fader you’re changing the parameters they are seeing. I think it makes more sense for that to be post-FX and cool that Reaper figured that out.


#9

Ah yes - one of the peculiar things Reaper is that when you automate the volume on a channel, by default it returns the channel fader to 0 on the screen.

I LOVE this because it means that if, for example, you have automated a vocal track to within an inch of its life, only to discover later that the whole lead vocal needs to come up 0.5 of a dB, you simply raise the fader that much and all the automation stays intact.

The bad thing about it is that… Well, I guess you’ve just discovered it! Generally, if I want to automate a track pre-fader I use a gain plugin like Sonalksis’ “Free G”.


#10

I love Free G. I also use it on the master buss at the end of the chain as a post-fx fader.


#11

That is awsome that those lunatics solved your problem… I personally would’ve got bored after 5 minutes.

I can barely follow the CSI (Control Surface Integrator) thread, and I have about four of them.


#12

Yeah, they’re great over there. Nice complement to IRD